Problems with WebMail on Britiac3

Discussion about BCA's Internet Hosting Service
User avatar
David Gibson
Posts: 479
Joined: Thu 16 Mar 2006 23:45

Problems with WebMail on Britiac3

Post by David Gibson » Sat 03 Sep 2016 10:16

Has anybody other than myself totally failed to get webmail to work on britiac3?

SMTP and POP3 servers are working fine, but none of the three offered webmail apps do anything other than sit there with a blank screen. Cookie - I have emailed you a couple of user accounts and passwords for you to try, so you can see this for yourself. If I switch on JavaScript error reporting, I get...

Code: Select all

Multiple 'X-Frame-Options' headers with conflicting values ('DENY, sameorigin') encountered when loading 'https://webmail.********/cpsess********/3rdparty/roundcube/?_task=mail'. Falling back to 'DENY'.

Refused to display 'https://webmail.********/cpsess********/3rdparty/roundcube/?_task=mail' in a frame because it set 'X-Frame-Options' to 'DENY, sameorigin'.

Uncaught SecurityError: Failed to read the 'contentDocument' property from 'HTMLIFrameElement': Sandbox access violation: Blocked a frame at "https://webmail.********" from accessing a frame at "null".  The frame being accessed is sandboxed and lacks the "allow-same-origin" flag.
This is in Chrome on Windows 10. Similar behaviour in XP. In Firefox on win10 the error might be slightly more informative. It says...

Code: Select all

The site specified an invalid Strict-Transport-Security header.
So is this a "certificates" problem, Cookie? How do I solve it? :-)

David Cooke
Site Admin
Posts: 299
Joined: Thu 29 Dec 2005 23:22
Location: Axbridge, Somerset, UK

Re: Problems with WebMail on Britiac3

Post by David Cooke » Mon 05 Sep 2016 15:39

Sorry, it works fine for me.

That error does look cert related. I'll have a look at the cert for you.
Dave Cooke
BCA IT Working Party, BCA Web Services, National Cave Registry Co-ordinator, CSCC Webmaster

User avatar
David Gibson
Posts: 479
Joined: Thu 16 Mar 2006 23:45

Re: Problems with WebMail on Britiac3

Post by David Gibson » Mon 05 Sep 2016 22:45

Ive tried it in yet another browser (MS Edge on Windows 10) and this gave me a more sensible error message. "There is supposed to be some content here...." and it went on, when I probed, to say "certificate error". I must confess I have never really got to grips with certificates and I do not understand why, with a perfectly "sane" setup (i.e. not one corrupted by me), on a new PC, it wont just let me in. What do I need to do?

User avatar
David Gibson
Posts: 479
Joined: Thu 16 Mar 2006 23:45

Re: Problems with WebMail on Britiac3

Post by David Gibson » Tue 13 Sep 2016 23:11

Hi Cookie. I got someone to try it on their SmartPhone and they couldnt get access either. But it does look like some sort of certificate error.

User avatar
David Gibson
Posts: 479
Joined: Thu 16 Mar 2006 23:45

Re: Problems with WebMail on Britiac3

Post by David Gibson » Thu 29 Sep 2016 09:32

I have asked more people to try this, on a variety of tablets, phones and PCs and nobody has been able to get access. There is definitely a serious problem, Cookie. The fact that you can get in merely means, I suspect, that youve tweaked your computer in some cunning certificate-related way that the rest of us do not know how to do. OR it means that you didnt get access after all, but only thought you did. The test mailbox I suggested you tried, is empty, so you have to double-check the difference between a display of an empty mailbox, and the display of a blank frame. :)

User avatar
David Gibson
Posts: 479
Joined: Thu 16 Mar 2006 23:45

Re: Problems with WebMail on Britiac3

Post by David Gibson » Thu 29 Sep 2016 14:40

OK.... I have a workaround. not bad, considering that know nothing about https and certificates. Instead of using the URL webmail.<my-website>.com, access is possible at http://britiac3.miniserver.com/webmail Im sure that will tell you straight away what the problem is, Cookie!

Post Reply