Problems with Mailman

Discussion about BCA's Internet Hosting Service
User avatar
David Gibson
Posts: 496
Joined: Thu 16 Mar 2006 23:45

Problems with Mailman

Post by David Gibson » Mon 07 Mar 2016 11:54

Cookie, ... and anyone else....
Is there any known problem with Mailman at the moment? It is behaving very oddly. Several people on the CREG-announce list are not receiving messages. I have checked the server log and it looks like they are not being sent; that is...
  • It is not a problem due to grey-listing or temporary delivery failure because there's nothing in the log
  • Its not a genuine non-delivery problem because there's nothing in the log (although plenty of people ARE being blocked due to "local policy" :-(
  • Its not the list that's blocking the sending because the NoMail box is not checked for these subscribers
  • Its not some other, undefined, problem with the transport because at least one affected person is receiving messages from one of the other lists.
Its as if the list has just "decided" not to send to half the people on the mailing list, but it is not reporting the fact. I need to run another test, but it looks as if the database might be corrupted, if that's possible, so I could just unsubscribe and resubscribe everyone I guess.

User avatar
David Gibson
Posts: 496
Joined: Thu 16 Mar 2006 23:45

Re: Problems with Mailman

Post by David Gibson » Wed 09 Mar 2016 14:03

This is distinctly odd. The list is not posting to the TLDs .ca, .com, .net, .org. Is it just co-incidental that those are in the groupings that Mailman apparently handles separately, viz, from https://mail.python.org/pipermail/mailm ... 72413.html ...
the entire list is split into four groups by top level domain. One group is all .com addresses, the second is .net and .org, the third is .edu, .us and .ca and the fourth is all others. Then the individual message recipients are taken in chunks of up to the limit in size from the groups.

User avatar
David Gibson
Posts: 496
Joined: Thu 16 Mar 2006 23:45

Re: Problems with Mailman

Post by David Gibson » Wed 09 Mar 2016 15:27

Apologies to those who subscribe to the Forum Scanner mail list. Im running some tests, which will result in your receiving several emails.

Post Reply